What’s Vulnerable › Vulnerabilities

CVE-2023-6386: Allocation of Resources Without Limits or Throttling in GitLab

Description

A denial of service vulnerability was identified in GitLab CE/EE, affecting all versions from 15.11 prior to 16.6.7, 16.7 prior to 16.7.5 and 16.8 prior to 16.8.2 which allows an attacker to spike the GitLab instance resource usage resulting in service degradation.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.6.7, 16.7.5, 16.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-6386 or the next vulnerability affects your stack