What’s Vulnerable › Vulnerabilities
CVE-2023-6461: Cross-site Scripting (XSS) - Reflected in viliusle/minipaint
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository viliusle/minipaint prior to 4.14.0.
Affected products
- viliusle/minipaint: before 4.14.0 — fixed in 4.14.0
How to fix
Upgrade to a fixed version: viliusle/minipaint 4.14.0. Check the vendor advisory for mitigations.
References
- https://github.com/viliusle/minipaint/commit/f22cb46515c91b1071d48fff3e6c9b92c9b3878c
- https://huntr.com/bounties/9a97d163-1738-4a09-b284-a04716e69dd0
- https://github.com/viliusle/minipaint/commit/f22cb46515c91b1071d48fff3e6c9b92c9b3878c
- https://huntr.com/bounties/9a97d163-1738-4a09-b284-a04716e69dd0
Get alerted when CVE-2023-6461 or the next vulnerability affects your stack