What’s Vulnerable › Vulnerabilities
CVE-2023-6478: Xorg-x11-server: out-of-bounds memory read in rrchangeoutputproperty and rrchangeproviderproperty
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-13 · updated 2026-06-23
- Weakness: CWE-190
Description
A flaw was found in xorg-server. A specially crafted request to RRChangeProviderProperty or RRChangeOutputProperty can trigger an integer overflow which may lead to a disclosure of sensitive information.
Affected products
- Debian Linux: 10.0, 11.0, 12.0
- RedHat Enterprise Linux Eus: 9.2
- Kaspersky TigerVNC: all versions
- xorg-x11-server: before 21.1.10 — fixed in 21.1.10
- X.Org xwayland: before 23.2.3 — fixed in 23.2.3
How to fix
Upgrade to a fixed version: xorg-x11-server 21.1.10; X.Org xwayland 23.2.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2023:7886
- https://access.redhat.com/errata/RHSA-2024:0006
- https://access.redhat.com/errata/RHSA-2024:0009
- https://access.redhat.com/errata/RHSA-2024:0010
- https://access.redhat.com/errata/RHSA-2024:0014
- https://access.redhat.com/errata/RHSA-2024:0015
- https://access.redhat.com/errata/RHSA-2024:0016
- https://access.redhat.com/errata/RHSA-2024:0017
- https://access.redhat.com/errata/RHSA-2024:0018
- https://access.redhat.com/errata/RHSA-2024:0020
- https://access.redhat.com/errata/RHSA-2024:2169
- https://access.redhat.com/errata/RHSA-2024:2170
Get alerted when CVE-2023-6478 or the next vulnerability affects your stack