What’s Vulnerable › Vulnerabilities
CVE-2023-6485: Html5 Video Player < 2.5.19 - Subscriber+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Html5 Video Player WordPress plugin before 2.5.19 does not sanitise and escape some of its player settings, which combined with missing capability checks around the plugin could allow any authenticated users, such as low as subscribers to perform Stored Cross-Site Scripting attacks against high privilege users like admins
Affected products
- bplugins HTML5 Video Player – Embed and Play Videos in Custom Player: before 2.5.19 — fixed in 2.5.19
How to fix
Upgrade to a fixed version: bplugins HTML5 Video Player – Embed and Play Videos in Custom Player 2.5.19. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/759b3866-c619-42cc-94a8-0af6d199cc81
- https://wpscan.com/vulnerability/759b3866-c619-42cc-94a8-0af6d199cc81
Get alerted when CVE-2023-6485 or the next vulnerability affects your stack