What’s Vulnerable › Vulnerabilities
CVE-2023-6487: LuckyWP Table of Contents <= 2.1.5 - Authenticated (Administrator+) Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The LuckyWP Table of Contents plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘Header Title' field in all versions up to and including 2.1.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled. CVE-2024-2218 appears to be a duplicate of this issue.
Affected products
- theluckywp LuckyWP Table of Contents: before 2.1.5 — fixed in 2.1.5
How to fix
Upgrade to a fixed version: theluckywp LuckyWP Table of Contents 2.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3147918%40luckywp-table-of-contents%2Ftrunk&old=3130057%40luckywp-table-of-contents%2Ftrunk&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/luckywp-table-of-contents/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/88075c15-079f-4de2-8e15-374eb7b8c77b?source=cve
- https://wordpress.org/plugins/luckywp-table-of-contents/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/88075c15-079f-4de2-8e15-374eb7b8c77b?source=cve
Get alerted when CVE-2023-6487 or the next vulnerability affects your stack