What’s Vulnerable › Vulnerabilities

CVE-2023-6489: Inefficient Regular Expression Complexity in GitLab

Description

A denial of service vulnerability was identified in GitLab CE/EE, versions 16.7.7 prior to 16.8.6, 16.9 prior to 16.9.4 and 16.10 prior to 16.10.2 which allows an attacker to spike the GitLab instance resources usage resulting in service degradation via chat integration feature.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.10.2, 16.8.6, 16.9.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-6489 or the next vulnerability affects your stack