What’s Vulnerable › Vulnerabilities
CVE-2023-6541: Allow SVG < 1.2.0 - Author+ Stored XSS via SVG
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Allow SVG WordPress plugin before 1.2.0 does not sanitize uploaded SVG files, which could allow users with a role as low as Author to upload a malicious SVG containing XSS payloads.
Affected products
- Allow SVG: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Allow SVG 1.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-6541 or the next vulnerability affects your stack