What’s Vulnerable › Vulnerabilities
CVE-2023-6549: Citrix NetScaler ADC and NetScaler Gateway Buffer Overflow Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-01-17
- EPSS: 57.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-17 · updated 2026-06-17
- Weakness: CWE-119
Description
Improper Restriction of Operations within the Bounds of a Memory Buffer in NetScaler ADC and NetScaler Gateway allows Unauthenticated Denial of Service and Out-Of-Bounds Memory Read
Summary
CVE-2023-6549 is a buffer overflow (improper restriction of operations within a memory buffer) in Citrix NetScaler ADC and NetScaler Gateway that allows unauthenticated denial of service and out-of-bounds memory reads. It is rated high severity (CVSS 7.5), is listed in CISA's Known Exploited Vulnerabilities catalog with active exploitation, and a public exploit or detection template exists; EPSS estimates a 57.6% chance of exploitation in 30 days. Affected are NetScaler ADC (fixed in 12.1-55.302, 13.0-92.21, 13.1-37.176, 13.1-51.15) and NetScaler Gateway (fixed in 13.0-92.21, 13.1-51.15, 14.1-12.35). Apply the vendor's fixed versions or mitigations promptly, or discontinue use of the product if mitigations are unavailable.
CVE-2023-6549 هو ثغرة تجاوز سعة المخزن المؤقت (عدم تقييد العمليات ضمن حدود المخزن المؤقت للذاكرة) في Citrix NetScaler ADC وNetScaler Gateway، وتتيح حجب الخدمة دون مصادقة وقراءة خارج حدود الذاكرة. صُنّفت عالية الخطورة (CVSS 7.5)، وهي مدرجة في كتالوج CISA للثغرات المعروفة باستغلالها مع استغلال نشط، ويتوفر استغلال عام أو قالب كشف؛ وتقدّر EPSS احتمال الاستغلال خلال 30 يوماً بنسبة 57.6%. تشمل المنتجات المتأثرة NetScaler ADC (تمت المعالجة في 12.1-55.302 و13.0-92.21 و13.1-37.176 و13.1-51.15) وNetScaler Gateway (تمت المعالجة في 13.0-92.21 و13.1-51.15 و14.1-12.35). طبّق الإصدارات المُصحّحة أو التخفيفات التي توصي بها الجهة المصنّعة فوراً، أو أوقف استخدام المنتج إذا لم تتوفر التخفيفات.
Affected products
- Citrix NetScaler ADC: from 13.0 before 13.0-92.21; from 13.1 before 13.1-51.15; from 14.1 before 14.1-12.35 — fixed in 13.0-92.21, 13.1-51.15, 14.1-12.35
- Citrix Netscaler Application Delivery Controller Fips: from 12.1 before 12.1-55.302; from 13.1 before 13.1-37.176 — fixed in 12.1-55.302, 13.1-37.176
- Citrix Netscaler Application Delivery Controller Ndcpp: from 12.1 before 12.1-55.302 — fixed in 12.1-55.302
- Citrix NetScaler Gateway: from 13.0 before 13.0-92.21; from 13.1 before 13.1-51.15; from 14.1 before 14.1-12.35 — fixed in 13.0-92.21, 13.1-51.15, 14.1-12.35
- Citrix NetScaler ADC: from 14.1 before 12.35; from 13.1 before 51.15; from 13.0 before 92.21; from 13.1-FIPS before 37.176; from 12.1-FIPS before 55.302; from 12.1-NDcPP before 55.302 — fixed in 12.35, 51.15, 92.21, 37.176, 55.302
How to fix
Upgrade to a fixed version: Citrix NetScaler ADC 13.0-92.21, 13.1-51.15, 14.1-12.35; Citrix Netscaler Application Delivery Controller Fips 12.1-55.302, 13.1-37.176; Citrix Netscaler Application Delivery Controller Ndcpp 12.1-55.302; Citrix NetScaler Gateway 13.0-92.21, 13.1-51.15, 14.1-12.35; Citrix NetScaler ADC 12.35, 51.15, 92.21, 37.176. Check the vendor advisory for mitigations.
References
- https://support.citrix.com/article/CTX584986/netscaler-adc-and-netscaler-gateway-security-bulletin-for-cve20236548-and-cve20236549
- https://support.citrix.com/article/CTX584986/netscaler-adc-and-netscaler-gateway-security-bulletin-for-cve20236548-and-cve20236549
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-6549
Get alerted when CVE-2023-6549 or the next vulnerability affects your stack