What’s Vulnerable › Vulnerabilities
CVE-2023-6567: LearnPress <= 4.2.5.7 - Unauthenticated SQL Injection via order_by
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 51.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-11 · updated 2026-06-17
- Weakness: CWE-89
Description
The LearnPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order_by’ parameter in all versions up to, and including, 4.2.5.7 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses: before 4.2.5.8 — fixed in 4.2.5.8
How to fix
Upgrade to a fixed version: thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses 4.2.5.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3013957/learnpress
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6ab578cd-3a0b-43d3-aaa7-0a01f431a4e2?source=cve
- https://plugins.trac.wordpress.org/changeset/3013957/learnpress
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6ab578cd-3a0b-43d3-aaa7-0a01f431a4e2?source=cve
Get alerted when CVE-2023-6567 or the next vulnerability affects your stack