What’s Vulnerable › Vulnerabilities
CVE-2023-6620: Post SMTP < 2.8.7 - Admin+ SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-15 · updated 2026-06-17
- Weakness: CWE-89
Description
The POST SMTP Mailer WordPress plugin before 2.8.7 does not properly sanitise and escape several parameters before using them in SQL statements, leading to a SQL injection exploitable by high privilege users such as admin.
Affected products
- saadiqbal Post SMTP – Complete Email Deliverability and SMTP Solution with Email Logs, Alerts, Backup SMTP & Mobile App: before 2.8.7 — fixed in 2.8.7
How to fix
Upgrade to a fixed version: saadiqbal Post SMTP – Complete Email Deliverability and SMTP Solution with Email Logs, Alerts, Backup SMTP & Mobile App 2.8.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ab5c42ca-ee7d-4344-bd88-0d727ed3d9c4
- https://wpscan.com/vulnerability/ab5c42ca-ee7d-4344-bd88-0d727ed3d9c4
Get alerted when CVE-2023-6620 or the next vulnerability affects your stack