What’s Vulnerable › Vulnerabilities
CVE-2023-6621: Post SMTP < 2.8.7 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The POST SMTP WordPress plugin before 2.8.7 does not sanitise and escape the msg parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- saadiqbal Post SMTP – Complete Email Deliverability and SMTP Solution with Email Logs, Alerts, Backup SMTP & Mobile App: before 2.8.7 — fixed in 2.8.7
How to fix
Upgrade to a fixed version: saadiqbal Post SMTP – Complete Email Deliverability and SMTP Solution with Email Logs, Alerts, Backup SMTP & Mobile App 2.8.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b49ca336-5bc2-4d72-a9a5-b8c020057928
- https://wpscan.com/vulnerability/b49ca336-5bc2-4d72-a9a5-b8c020057928
Get alerted when CVE-2023-6621 or the next vulnerability affects your stack