What’s Vulnerable › Vulnerabilities
CVE-2023-6626: Product Enquiry for WooCommerce < 3.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Product Enquiry for WooCommerce WordPress plugin before 3.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Product Enquiry for WooCommerce: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: Product Enquiry for WooCommerce 3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/327ae124-79eb-4e07-b029-e4f543cbd356/
- https://wpscan.com/vulnerability/327ae124-79eb-4e07-b029-e4f543cbd356/
Get alerted when CVE-2023-6626 or the next vulnerability affects your stack