What’s Vulnerable › Vulnerabilities
CVE-2023-6637: CAOS | Host Google Analytics Locally <= 4.7.14 - Missing Authorization to Unauthenticated Plugin Settings Update
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-11 · updated 2026-06-17
- Weakness: CWE-862
Description
The CAOS | Host Google Analytics Locally plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'update_settings' function in versions up to, and including, 4.7.14. This makes it possible for unauthenticated attackers to update plugin settings.
Affected products
- daanvandenbergh CAOS | Host Google Analytics Locally: before 4.7.15 — fixed in 4.7.15
How to fix
Upgrade to a fixed version: daanvandenbergh CAOS | Host Google Analytics Locally 4.7.15. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/host-analyticsjs-local/tags/4.7.12/includes/class-caos.php#L414
- https://plugins.trac.wordpress.org/changeset/3008878/host-analyticsjs-local#file8
- https://plugins.trac.wordpress.org/changeset/3009011/host-analyticsjs-local#file5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5ec1fd03-f865-4f58-b63b-e70c0c7e701d?source=cve
- https://plugins.trac.wordpress.org/browser/host-analyticsjs-local/tags/4.7.12/includes/class-caos.php#L414
- https://plugins.trac.wordpress.org/changeset/3008878/host-analyticsjs-local#file8
- https://plugins.trac.wordpress.org/changeset/3009011/host-analyticsjs-local#file5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5ec1fd03-f865-4f58-b63b-e70c0c7e701d?source=cve
Get alerted when CVE-2023-6637 or the next vulnerability affects your stack