What’s Vulnerable › Vulnerabilities
CVE-2023-6680: Improper Certificate Validation in GitLab
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-15 · updated 2026-06-17
- Weakness: CWE-295
Description
An improper certificate validation issue in Smartcard authentication in GitLab EE affecting all versions from 11.6 prior to 16.4.4, 16.5 prior to 16.5.4, and 16.6 prior to 16.6.2 allows an attacker to authenticate as another user given their public key if they use Smartcard authentication. Smartcard authentication is an experimental feature and has to be manually enabled by an administrator.
Affected products
- GitLab: from 11.6 before 16.4.4; from 16.5 before 16.5.4; from 16.6 before 16.6.2 — fixed in 16.4.4, 16.5.4, 16.6.2
How to fix
Upgrade to a fixed version: GitLab 16.4.4, 16.5.4, 16.6.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/421607
- https://gitlab.com/gitlab-org/gitlab/-/issues/421607
Get alerted when CVE-2023-6680 or the next vulnerability affects your stack