What’s Vulnerable › Vulnerabilities
CVE-2023-6711
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-19 · updated 2026-06-17
- Weakness: CWE-120
Description
Vulnerability exists in SCI IEC 60870-5-104 and HCI IEC 60870-5-104 that affects the RTU500 series product versions listed below. Specially crafted messages sent to the mentioned components are not validated properly and can result in buffer overflow and as final consequence to a reboot of an RTU500 CMU.
Affected products
- Hitachi Energy RTU500 series CMU firmware: from 12.0.1.0 before 12.0.15.0; from 12.2.1.0 before 12.2.12.0; from 12.4.1.0 before 12.4.12.0; from 12.6.1.0 before 12.6.10.0; from 12.7.1.0 before 12.7.7.0; from 13.2.1.0 before 13.2.7.0 — fixed in 12.0.15.0, 12.2.12.0, 12.4.12.0, 12.6.10.0, 12.7.7.0, 13.2.7.0
How to fix
Upgrade to a fixed version: Hitachi Energy RTU500 series CMU firmware 12.0.15.0, 12.2.12.0, 12.4.12.0, 12.6.10.0. Check the vendor advisory for mitigations.
References
- https://publisher.hitachienergy.com/preview?DocumentId=8DBD000184&languageCode=en&Preview=true
- https://publisher.hitachienergy.com/preview?DocumentId=8DBD000184&languageCode=en&Preview=true
Get alerted when CVE-2023-6711 or the next vulnerability affects your stack