What’s Vulnerable › Vulnerabilities
CVE-2023-6738: PageLayer <= 1.7.8 - Authenticated(Contributor+) Stored Cross-Site Scripting via meta fields
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-04 · updated 2026-06-17
- Weakness: CWE-20
Description
The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pagelayer_header_code', 'pagelayer_body_open_code', and 'pagelayer_footer_code' meta fields in all versions up to, and including, 1.7.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This appears to be a reintroduction of a vulnerability patched in version 1.7.7.
Affected products
References
- https://plugins.trac.wordpress.org/browser/pagelayer/trunk/main/post_metas.php#L527
- https://plugins.trac.wordpress.org/changeset?old_path=/pagelayer/tags/1.7.8&old=3016486&new_path=/pagelayer/tags/1.7.9&new=3016486&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d14c8890-482c-4d43-a68f-0d04c4feca8f?source=cve
- https://plugins.trac.wordpress.org/browser/pagelayer/trunk/main/post_metas.php#L527
- https://plugins.trac.wordpress.org/changeset?old_path=/pagelayer/tags/1.7.8&old=3016486&new_path=/pagelayer/tags/1.7.9&new=3016486&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d14c8890-482c-4d43-a68f-0d04c4feca8f?source=cve
Get alerted when CVE-2023-6738 or the next vulnerability affects your stack