What’s Vulnerable › Vulnerabilities
CVE-2023-6744: Divi <= 4.23.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Divi theme for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'et_pb_text' shortcode in all versions up to, and including, 4.23.1 due to insufficient input sanitization and output escaping on user supplied custom field data. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Elegant Themes Divi: before 4.23.2 — fixed in 4.23.2
How to fix
Upgrade to a fixed version: Elegant Themes Divi 4.23.2. Check the vendor advisory for mitigations.
References
- https://www.elegantthemes.com/api/changelog/divi.txt
- https://www.wordfence.com/threat-intel/vulnerabilities/id/999475c5-5f17-47fa-a0d0-47cb5a8a0eb4?source=cve
- https://www.elegantthemes.com/api/changelog/divi.txt
- https://www.wordfence.com/threat-intel/vulnerabilities/id/999475c5-5f17-47fa-a0d0-47cb5a8a0eb4?source=cve
Get alerted when CVE-2023-6744 or the next vulnerability affects your stack