What’s Vulnerable › Vulnerabilities
CVE-2023-6789: PAN-OS: Stored Cross-Site Scripting (XSS) Vulnerability in the Web Interface
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS software enables a malicious authenticated read-write administrator to store a JavaScript payload using the web interface. Then, when viewed by a properly authenticated administrator, the JavaScript payload executes and disguises all associated actions as performed by that unsuspecting authenticated administrator.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.26; from 9.0.0 before 9.0.17; from 9.1.0 before 9.1.17; from 10.1.0 before 10.1.11; from 10.2.0 before 10.2.5; from 11.0.0 before 11.0.2 — fixed in 8.1.26, 9.0.17, 9.1.17, 10.1.11, 10.2.5, 11.0.2
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.26; from 9.0 before 9.0.17-h4; from 9.1 before 9.1.17; from 10.0; from 10.1 before 10.1.11; from 10.2 before 10.2.5 — fixed in 8.1.26, 9.0.17-h4, 9.1.17, 10.1.11, 10.2.5, 11.0.2
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.26, 9.0.17, 9.1.17, 10.1.11; Palo Alto Networks PAN-OS 8.1.26, 9.0.17-h4, 9.1.17, 10.1.11. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2023-6789
- https://security.paloaltonetworks.com/CVE-2023-6789
Get alerted when CVE-2023-6789 or the next vulnerability affects your stack