What’s Vulnerable › Vulnerabilities
CVE-2023-6790: PAN-OS: DOM-Based Cross-Site Scripting (XSS) Vulnerability in the Web Interface
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
A DOM-Based cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS software enables a remote attacker to execute a JavaScript payload in the context of an administrator’s browser when they view a specifically crafted link to the PAN-OS web interface.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.25; from 9.0.0 before 9.0.17; from 9.1.0 before 9.1.16; from 10.0.0 before 10.0.12; from 10.1.0 before 10.1.9; from 10.2.0 before 10.2.4 — fixed in 8.1.25, 9.0.17, 9.1.16, 10.0.12, 10.1.9, 10.2.4
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.25; from 9.0 before 9.0.17; from 9.1 before 9.1.16; from 10.0 before 10.0.12; from 10.1 before 10.1.9; from 10.2 before 10.2.4 — fixed in 8.1.25, 9.0.17, 9.1.16, 10.0.12, 10.1.9, 10.2.4
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.25, 9.0.17, 9.1.16, 10.0.12; Palo Alto Networks PAN-OS 8.1.25, 9.0.17, 9.1.16, 10.0.12. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2023-6790
- https://security.paloaltonetworks.com/CVE-2023-6790
Get alerted when CVE-2023-6790 or the next vulnerability affects your stack