What’s Vulnerable › Vulnerabilities
CVE-2023-6792: PAN-OS: OS Command Injection Vulnerability in the XML API
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-13 · updated 2026-06-17
- Weakness: CWE-88
Description
An OS command injection vulnerability in the XML API of Palo Alto Networks PAN-OS software enables an authenticated API user to disrupt system processes and potentially execute arbitrary code with limited privileges on the firewall.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.24; from 9.0.0 before 9.0.17; from 9.1.0 before 9.1.15; from 10.0.0 before 10.0.12; from 10.1.0 before 10.1.6 — fixed in 8.1.24, 9.0.17, 9.1.15, 10.0.12, 10.1.6
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.24; from 9.0 before 9.0.17; from 9.1 before 9.1.15; from 10.0 before 10.0.12; from 10.1 before 10.1.6 — fixed in 8.1.24, 9.0.17, 9.1.15, 10.0.12, 10.1.6, 10.2
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.24, 9.0.17, 9.1.15, 10.0.12; Palo Alto Networks PAN-OS 8.1.24, 9.0.17, 9.1.15, 10.0.12. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2023-6792
- https://security.paloaltonetworks.com/CVE-2023-6792
Get alerted when CVE-2023-6792 or the next vulnerability affects your stack