What’s Vulnerable › Vulnerabilities
CVE-2023-6806: Starbox <= 3.4.8 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Job Settings
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Starbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Job Settings user profile fields in all versions up to, and including, 3.4.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- cifi Starbox – the Author Box for Humans: before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: cifi Starbox – the Author Box for Humans 3.5.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3029599/starbox
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1f413fc2-8543-4478-987d-d983581027bf?source=cve
- https://plugins.trac.wordpress.org/changeset/3029599/starbox
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1f413fc2-8543-4478-987d-d983581027bf?source=cve
Get alerted when CVE-2023-6806 or the next vulnerability affects your stack