What’s Vulnerable › Vulnerabilities
CVE-2023-6848: kalcaddle kodbox index.class.php check command injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-16 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability was found in kalcaddle kodbox up to 1.48. It has been declared as critical. Affected by this vulnerability is the function check of the file plugins/officeViewer/controller/libreOffice/index.class.php. The manipulation of the argument soffice leads to command injection. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.48.04 is able to address this issue. The identifier of the patch is 63a4d5708d210f119c24afd941d01a943e25334c. It is recommended to upgrade the affected component. The identifier VDB-248209 was assigned to this vulnerability.
Affected products
- kalcaddle kodbox: before 1.48.04 — fixed in 1.48.04
How to fix
Upgrade to a fixed version: kalcaddle kodbox 1.48.04. Check the vendor advisory for mitigations.
References
- https://github.com/kalcaddle/kodbox/commit/63a4d5708d210f119c24afd941d01a943e25334c
- https://github.com/kalcaddle/kodbox/releases/tag/1.48.04
- https://note.zhaoj.in/share/pf838kAzQyTQ
- https://vuldb.com/?ctiid.248209
- https://vuldb.com/?id.248209
- https://github.com/kalcaddle/kodbox/commit/63a4d5708d210f119c24afd941d01a943e25334c
- https://github.com/kalcaddle/kodbox/releases/tag/1.48.04
- https://note.zhaoj.in/share/pf838kAzQyTQ
- https://vuldb.com/?ctiid.248209
- https://vuldb.com/?id.248209
Get alerted when CVE-2023-6848 or the next vulnerability affects your stack