What’s Vulnerable › Vulnerabilities
CVE-2023-6852: kalcaddle KodExplorer app.php server-side request forgery
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-16 · updated 2026-06-17
- Weakness: CWE-918
Description
A vulnerability classified as critical has been found in kalcaddle KodExplorer up to 4.51.03. Affected is an unknown function of the file plugins/webodf/app.php. The manipulation leads to server-side request forgery. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.52.01 is able to address this issue. The name of the patch is 5cf233f7556b442100cf67b5e92d57ceabb126c6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-248220.
Affected products
- kalcaddle KodExplorer: before 4.52.01 — fixed in 4.52.01
How to fix
Upgrade to a fixed version: kalcaddle KodExplorer 4.52.01. Check the vendor advisory for mitigations.
References
- https://github.com/kalcaddle/KodExplorer/commit/5cf233f7556b442100cf67b5e92d57ceabb126c6
- https://github.com/kalcaddle/KodExplorer/releases/tag/4.52.01
- https://note.zhaoj.in/share/P6lQNyqQn3zY
- https://vuldb.com/?ctiid.248220
- https://vuldb.com/?id.248220
- https://github.com/kalcaddle/KodExplorer/commit/5cf233f7556b442100cf67b5e92d57ceabb126c6
- https://github.com/kalcaddle/KodExplorer/releases/tag/4.52.01
- https://note.zhaoj.in/share/P6lQNyqQn3zY
- https://vuldb.com/?ctiid.248220
- https://vuldb.com/?id.248220
Get alerted when CVE-2023-6852 or the next vulnerability affects your stack