What’s Vulnerable › Vulnerabilities
CVE-2023-6892: EAN for WooCommerce <= 4.9.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via alg_wc_ean_product_meta Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The EAN for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'alg_wc_ean_product_meta' shortcode in all versions up to, and including, 4.8.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPFactory EAN for WooCommerce: before 4.9.3 — fixed in 4.9.3
How to fix
Upgrade to a fixed version: WPFactory EAN for WooCommerce 4.9.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3070991/ean-for-woocommerce
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d798406b-2b7f-4ca0-8d05-8aff4bf44dd8?source=cve
- https://plugins.trac.wordpress.org/changeset/3070991/ean-for-woocommerce
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d798406b-2b7f-4ca0-8d05-8aff4bf44dd8?source=cve
Get alerted when CVE-2023-6892 or the next vulnerability affects your stack