What’s Vulnerable › Vulnerabilities
CVE-2023-6895: Hikvision Intercom Broadcasting System ping.php os command injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 89.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-17 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability was found in Hikvision Intercom Broadcasting System 3.0.3_20201113_RELEASE(HIK). It has been declared as critical. This vulnerability affects unknown code of the file /php/ping.php. The manipulation of the argument jsondata[ip] with the input netstat -ano leads to os command injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.0 is able to address this issue. It is recommended to upgrade the affected component. VDB-248254 is the identifier assigned to this vulnerability.
Affected products
- Hikvision Intercom Broadcasting System: from 3.0.3 before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: Hikvision Intercom Broadcasting System 4.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/willchen0011/cve/blob/main/rce.md
- https://vuldb.com/?ctiid.248254
- https://vuldb.com/?id.248254
- https://github.com/willchen0011/cve/blob/main/rce.md
- https://vuldb.com/?ctiid.248254
- https://vuldb.com/?id.248254
Get alerted when CVE-2023-6895 or the next vulnerability affects your stack