What’s Vulnerable › Vulnerabilities
CVE-2023-6897: EAN for WooCommerce <= 4.9.2 - Insecure Direct Object Reference to Sensitve Information Exposure via Shortcode
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-639
Description
The EAN for WooCommerce plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 4.9.2 via the the 'alg_wc_ean_product_meta' shortcode due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with contributor-level access and above, to expose potentially sensitive post metadata.
Affected products
- WPFactory EAN for WooCommerce: before 4.9.3 — fixed in 4.9.3
How to fix
Upgrade to a fixed version: WPFactory EAN for WooCommerce 4.9.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3070991/ean-for-woocommerce
- https://www.wordfence.com/threat-intel/vulnerabilities/id/17b20df5-4adf-47ce-bddf-2ec0b9499de8?source=cve
- https://plugins.trac.wordpress.org/changeset/3070991/ean-for-woocommerce
- https://www.wordfence.com/threat-intel/vulnerabilities/id/17b20df5-4adf-47ce-bddf-2ec0b9499de8?source=cve
Get alerted when CVE-2023-6897 or the next vulnerability affects your stack