What’s Vulnerable › Vulnerabilities
CVE-2023-6917: Pcp: unsafe use of directories allows pcp to root privilege escalation
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-367
Description
A vulnerability has been identified in the Performance Co-Pilot (PCP) package, stemming from the mixed privilege levels utilized by systemd services associated with PCP. While certain services operate within the confines of limited PCP user/group privileges, others are granted full root privileges. This disparity in privilege levels poses a risk when privileged root processes interact with directories or directory trees owned by unprivileged PCP users. Specifically, this vulnerability may lead to the compromise of PCP user isolation and facilitate local PCP-to-root exploits, particularly through symlink attacks. These vulnerabilities underscore the importance of maintaining robust privilege separation mechanisms within PCP to mitigate the potential for unauthorized privilege escalation.
Affected products
- Red Hat Enterprise Linux: 9.0
- Sgi Performance Co-Pilot: before 6.2.0 — fixed in 6.2.0
How to fix
Upgrade to a fixed version: Sgi Performance Co-Pilot 6.2.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2024:2213
- https://access.redhat.com/security/cve/CVE-2023-6917
- https://bugzilla.redhat.com/show_bug.cgi?id=2254983
- https://access.redhat.com/errata/RHSA-2024:2213
- https://access.redhat.com/security/cve/CVE-2023-6917
- https://bugzilla.redhat.com/show_bug.cgi?id=2254983
Get alerted when CVE-2023-6917 or the next vulnerability affects your stack