What’s Vulnerable › Vulnerabilities
CVE-2023-6923: Matomo <= 4.15.3 - Reflected Cross-Site Scripting via idsite
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Matomo Analytics – Ethical Stats. Powerful Insights. plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the idsite parameter in all versions up to, and including, 4.15.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- matomoteam Matomo Analytics – Powerful, Privacy-First Insights for WordPress: before 5.0.1 — fixed in 5.0.1
How to fix
Upgrade to a fixed version: matomoteam Matomo Analytics – Powerful, Privacy-First Insights for WordPress 5.0.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3031495%40matomo&new=3031495%40matomo&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2e2d54eb-c176-49c4-a4fc-833e17189cad?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3031495%40matomo&new=3031495%40matomo&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2e2d54eb-c176-49c4-a4fc-833e17189cad?source=cve
Get alerted when CVE-2023-6923 or the next vulnerability affects your stack