What’s Vulnerable › Vulnerabilities
CVE-2023-6933: Better Search Replace <= 1.4.4 - Unauthenticated PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 68.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-05 · updated 2026-06-17
- Weakness: CWE-502
Description
The Better Search Replace plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.4.4 via deserialization of untrusted input. This makes it possible for unauthenticated attackers to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- wpengine Better Search Replace: before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: wpengine Better Search Replace 1.4.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/better-search-replace/trunk/includes/class-bsr-db.php#L334
- https://plugins.trac.wordpress.org/changeset/3023674/better-search-replace/trunk/includes/class-bsr-db.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/895f2db1-a2ed-4a17-a4f6-cd13ee8f84af?source=cve
- https://plugins.trac.wordpress.org/browser/better-search-replace/trunk/includes/class-bsr-db.php#L334
- https://plugins.trac.wordpress.org/changeset/3023674/better-search-replace/trunk/includes/class-bsr-db.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/895f2db1-a2ed-4a17-a4f6-cd13ee8f84af?source=cve
Get alerted when CVE-2023-6933 or the next vulnerability affects your stack