What’s Vulnerable › Vulnerabilities
CVE-2023-6936: Heap-buffer over-read with WOLFSSL_CALLBACKS
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-125
Description
In wolfSSL prior to 5.6.6, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS client or network attacker can trigger a buffer over-read on the heap of 5 bytes (WOLFSSL_CALLBACKS is only intended for debugging).
Affected products
- wolfSSL: before 5.6.6 — fixed in 5.6.6
How to fix
Upgrade to a fixed version: wolfSSL 5.6.6. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/pull/6949/
- https://www.wolfssl.com/docs/security-vulnerabilities/
- https://github.com/wolfSSL/wolfssl/pull/6949/
- https://www.wolfssl.com/docs/security-vulnerabilities/
Get alerted when CVE-2023-6936 or the next vulnerability affects your stack