What’s Vulnerable › Vulnerabilities
CVE-2023-6940: Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-19 · updated 2026-06-17
- Weakness: CWE-77
Description
with only one user interaction(download a malicious config), attackers can gain full command execution on the victim system.
Affected products
- mlflow/mlflow: before 2.9.2 — fixed in 2.9.2
How to fix
Upgrade to a fixed version: mlflow/mlflow 2.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/mlflow/mlflow/commit/5139b1087d686fa52e2b087e09da66aff86297b1
- https://huntr.com/bounties/c6f59480-ce47-4f78-a3dc-4bd8ca15029c
- https://github.com/mlflow/mlflow/commit/5139b1087d686fa52e2b087e09da66aff86297b1
- https://huntr.com/bounties/c6f59480-ce47-4f78-a3dc-4bd8ca15029c
Get alerted when CVE-2023-6940 or the next vulnerability affects your stack