What’s Vulnerable › Vulnerabilities
CVE-2023-6948
- Severity: low (CVSS 3.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-02 · updated 2026-06-17
- Weakness: CWE-120
Description
A Buffer Copy without Checking Size of Input issue affecting the v2_sdk_service running on a set of DJI drone devices on the port 10000 could allow an attacker to cause a crash of the service through a crafted payload triggering a missing input size check in the sdk_printf function implemented in the libv2_sdk.so library used by the dji_vtwo_sdk binary implementing the service, compromising it in a term of availability and producing a denial-of-service attack. Affected models are Mavic 3 Pro until v01.01.0300, Mavic 3 until v01.00.1200, Mavic 3 Classic until v01.00.0500, Mavic 3 Enterprise until v07.01.10.03, Matrice 300 until v57.00.01.00, Matrice M30 until v07.01.0022 and Mini 3 Pro until v01.00.0620.
Affected products
- DJI Matrice 300: before 57.00.01.00 — fixed in 57.00.01.00
- DJI Matrice M30: before 07.01.0022 — fixed in 07.01.0022
- DJI Mavic 3: before 01.00.1200 — fixed in 01.00.1200
- DJI Mavic 3 Classic: before 01.00.0500 — fixed in 01.00.0500
- DJI Mavic 3 Enterprise: before 7.01.10.03 — fixed in 7.01.10.03
- DJI Mavic 3 Pro: before 01.01.0300 — fixed in 01.01.0300
- DJI Mini 3 Pro: before 01.00.0620 — fixed in 01.00.0620
How to fix
Upgrade to a fixed version: DJI Matrice 300 57.00.01.00; DJI Matrice M30 07.01.0022; DJI Mavic 3 01.00.1200; DJI Mavic 3 Classic 01.00.0500; DJI Mavic 3 Enterprise 7.01.10.03; DJI Mavic 3 Pro 01.01.0300; DJI Mini 3 Pro 01.00.0620. Check the vendor advisory for mitigations.
References
- https://www.nozominetworks.com/labs/vulnerability-advisories-cve-2023-6948/
- https://www.nozominetworks.com/labs/vulnerability-advisories-cve-2023-6948/
Get alerted when CVE-2023-6948 or the next vulnerability affects your stack