What’s Vulnerable › Vulnerabilities
CVE-2023-6959: Getwid – Gutenberg Blocks <= 2.0.4 - Missing Authorization to Recaptcha API Key Modification
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-05 · updated 2026-06-17
- Weakness: CWE-862
Description
The Getwid – Gutenberg Blocks plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the recaptcha_api_key_manage function in all versions up to, and including, 2.0.3. This makes it possible for authenticated attackers, with subscriber-level access and above, to add, modify, or delete the 'Recaptcha Site Key' and 'Recaptcha Secret Key' settings.
Affected products
- jetmonsters Getwid – Gutenberg Blocks: before 2.0.5 — fixed in 2.0.5
How to fix
Upgrade to a fixed version: jetmonsters Getwid – Gutenberg Blocks 2.0.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3022982
- https://www.wordfence.com/threat-intel/vulnerabilities/id/774c00fb-82cd-44ca-bf96-3f6dfd1977d0?source=cve
- https://plugins.trac.wordpress.org/changeset/3022982
- https://www.wordfence.com/threat-intel/vulnerabilities/id/774c00fb-82cd-44ca-bf96-3f6dfd1977d0?source=cve
Get alerted when CVE-2023-6959 or the next vulnerability affects your stack