What’s Vulnerable › Vulnerabilities
CVE-2023-6965: Pods - Custom Content Types and Fields - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-862
Description
The Pods – Custom Content Types and Fields plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 3.0.10 (with the exception of 2.7.31.2, 2.8.23.2, 2.9.19.2). This is due to the fact that the plugin allows the use of a file inclusion feature via shortcode. This makes it possible for authenticated attackers, with contributor access or higher, to create pods and users (with default role).
Affected products
- sc0ttkclark Pods – Custom Content Types and Fields: before 2.7.31.2; from 2.8 before 2.8.23.2; from 2.9 before 2.9.19.2; from 3.0.0 before 3.0.10.2 — fixed in 2.7.31.2, 2.8.23.2, 2.9.19.2, 3.0.10.2
How to fix
Upgrade to a fixed version: sc0ttkclark Pods – Custom Content Types and Fields 2.7.31.2, 2.8.23.2, 2.9.19.2, 3.0.10.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/pods/trunk/classes/PodsView.php#L750
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3039486%40pods%2Ftrunk&old=3039467%40pods%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c5d330cd-ad1f-451e-bf41-39cfeb296cf0?source=cve
- https://plugins.trac.wordpress.org/browser/pods/trunk/classes/PodsView.php#L750
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3039486%40pods%2Ftrunk&old=3039467%40pods%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c5d330cd-ad1f-451e-bf41-39cfeb296cf0?source=cve
Get alerted when CVE-2023-6965 or the next vulnerability affects your stack