What’s Vulnerable › Vulnerabilities
CVE-2023-6968: The Moneytizer <= 9.6.3 - Cross-Site Request Forgery via multiple AJAX actions
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-284
Description
The The Moneytizer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 9.6.3. This is due to missing or incorrect nonce validation on multiple AJAX functions. This makes it possible for unauthenticated attackers to to update and retrieve billing and bank details, update and reset the plugin's settings, and update languages as well as other lower-severity actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- lvaudore The Moneytizer: before 10.0.1 — fixed in 10.0.1
How to fix
Upgrade to a fixed version: lvaudore The Moneytizer 10.0.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3099347/the-moneytizer/trunk/core/core_ajax.php?old=3038641&old_path=the-moneytizer%2Ftrunk%2Fcore%2Fcore_ajax.php
- https://wordpress.org/plugins/the-moneytizer/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/14351561-bd31-4aaa-931a-e72917458013?source=cve
- https://wordpress.org/plugins/the-moneytizer/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/14351561-bd31-4aaa-931a-e72917458013?source=cve
Get alerted when CVE-2023-6968 or the next vulnerability affects your stack