What’s Vulnerable › Vulnerabilities
CVE-2023-6972: Backup Migration <= 1.3.9 - Unauthenticated Path Traversal to Arbitrary File Deletion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-23 · updated 2026-06-17
- Weakness: CWE-22
Description
The Backup Migration plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.3.9 via the 'content-backups' and 'content-name', 'content-manifest', or 'content-bmitmp' and 'content-identy' HTTP headers. This makes it possible for unauthenticated attackers to delete arbitrary files, including the wp-config.php file, which can make site takeover and remote code execution possible.
Affected products
- inisev BackupBliss – Backup & Migration with Free Cloud Storage: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: inisev BackupBliss – Backup & Migration with Free Cloud Storage 1.4.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/backup-backup/tags/1.3.9/includes/backup-heart.php
- https://plugins.trac.wordpress.org/browser/backup-backup/tags/1.3.9/includes/bypasser.php
- https://plugins.trac.wordpress.org/changeset/3012745/backup-backup
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0a3ae696-f67d-4ed2-b307-d2f36b6f188c?source=cve
- https://plugins.trac.wordpress.org/browser/backup-backup/tags/1.3.9/includes/backup-heart.php
- https://plugins.trac.wordpress.org/browser/backup-backup/tags/1.3.9/includes/bypasser.php
- https://plugins.trac.wordpress.org/changeset/3012745/backup-backup
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0a3ae696-f67d-4ed2-b307-d2f36b6f188c?source=cve
Get alerted when CVE-2023-6972 or the next vulnerability affects your stack