What’s Vulnerable › Vulnerabilities
CVE-2023-6991: JSM file_get_contents() Shortcode < 2.7.1 - Contributor+ SSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-15 · updated 2026-06-17
- Weakness: CWE-918
Description
The JSM file_get_contents() Shortcode WordPress plugin before 2.7.1 does not validate one of its shortcode's parameters before making a request to it, which could allow users with contributor role and above to perform SSRF attacks.
Affected products
- JSM file_get_contents() Shortcode: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: JSM file_get_contents() Shortcode 2.7.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0b92becb-8a47-48fd-82e8-f7641cf5c9bc
- https://wpscan.com/vulnerability/0b92becb-8a47-48fd-82e8-f7641cf5c9bc
Get alerted when CVE-2023-6991 or the next vulnerability affects your stack