What’s Vulnerable › Vulnerabilities
CVE-2023-6999: Pods - Custom Content Types and Fields - Authenticated (Contributor+) Remote Code Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-77
Description
The Pods – Custom Content Types and Fields plugin for WordPress is vulnerable to Remote Code Exxecution via shortcode in all versions up to, and including, 3.0.10 (with the exception of 2.7.31.2, 2.8.23.2, 2.9.19.2). This makes it possible for authenticated attackers, with contributor level access or higher, to execute code on the server.
Affected products
- sc0ttkclark Pods – Custom Content Types and Fields: before 2.7.31.2; from 2.8 before 2.8.23.2; from 2.9 before 2.9.19.2; from 3.0.0 before 3.0.10.2 — fixed in 2.7.31.2, 2.8.23.2, 2.9.19.2, 3.0.10.2
How to fix
Upgrade to a fixed version: sc0ttkclark Pods – Custom Content Types and Fields 2.7.31.2, 2.8.23.2, 2.9.19.2, 3.0.10.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/pods/trunk/classes/PodsView.php#L750
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3039486%40pods%2Ftrunk&old=3039467%40pods%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9108d5f-7b8b-478d-ba9d-f895bdb7dbf2?source=cve
- https://plugins.trac.wordpress.org/browser/pods/trunk/classes/PodsView.php#L750
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3039486%40pods%2Ftrunk&old=3039467%40pods%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9108d5f-7b8b-478d-ba9d-f895bdb7dbf2?source=cve
Get alerted when CVE-2023-6999 or the next vulnerability affects your stack