What’s Vulnerable › Vulnerabilities
CVE-2023-7064: Shortcodes and extra features for Phlox theme <= 2.17.5 - Authenticated (Subscriber+) PHP Object Injection via auxin_template_control_importer
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-502
Description
The Shortcodes and extra features for Phlox theme plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.17.5 via deserialization of untrusted input from the vulnerable 'id' parameter in the 'auxin_template_control_importer' function. This makes it possible for authenticated attackers able to upload a separate PHAR payload as an image file to inject a PHP Object, though the action itself is available to subscribers. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- averta Shortcodes and extra features for Phlox theme: before 2.17.6 — fixed in 2.17.6
How to fix
Upgrade to a fixed version: averta Shortcodes and extra features for Phlox theme 2.17.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/auxin-elements/trunk/admin/includes/admin-ajax.php?annotate=blame&rev=3251498
- https://plugins.trac.wordpress.org/changeset/3251498
- https://plugins.trac.wordpress.org/changeset/3271715/
- https://wordpress.org/plugins/auxin-elements/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f0882205-3037-4ada-9e44-ddd55d88fcb1?source=cve
- https://wordpress.org/plugins/auxin-elements/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f0882205-3037-4ada-9e44-ddd55d88fcb1?source=cve
Get alerted when CVE-2023-7064 or the next vulnerability affects your stack