What’s Vulnerable › Vulnerabilities
CVE-2023-7067: ShopLentor <= 2.8.1 - Improper Authorization via woolentor_template_store
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-862
Description
The ShopLentor – WooCommerce Builder for Elementor & Gutenberg +10 Modules – All in One Solution (formerly WooLentor) plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'woolentor_template_store' function in all versions up to, and including, 2.8.1. This makes it possible for authenticated attackers, with contributor access and above to access the nonce used to access this function and set a blank template as the default template.
Affected products
- devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin: before 2.8.2 — fixed in 2.8.2
How to fix
Upgrade to a fixed version: devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin 2.8.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3044764/woolentor-addons/trunk?contextall=1&old=3037382&old_path=%2Fwoolentor-addons%2Ftrunk
- https://www.wordfence.com/threat-intel/vulnerabilities/id/860c2339-b2a9-4a4e-a186-07a5fb042b06?source=cve
- https://plugins.trac.wordpress.org/changeset/3044764/woolentor-addons/trunk?contextall=1&old=3037382&old_path=%2Fwoolentor-addons%2Ftrunk
- https://www.wordfence.com/threat-intel/vulnerabilities/id/860c2339-b2a9-4a4e-a186-07a5fb042b06?source=cve
Get alerted when CVE-2023-7067 or the next vulnerability affects your stack