What’s Vulnerable › Vulnerabilities
CVE-2023-7114
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-29 · updated 2026-06-17
- Weakness: CWE-74
Description
Mattermost version 2.10.0 and earlier fails to sanitize deeplink paths, which allows an attacker to perform CSRF attacks against the server.
Affected products
- Mattermost App Framework: before 2.10.1 — fixed in 2.10.1
How to fix
Upgrade to a fixed version: Mattermost App Framework 2.10.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-7114 or the next vulnerability affects your stack