What’s Vulnerable › Vulnerabilities
CVE-2023-7115: PageLayer < 1.8.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Builder: Pagelayer WordPress plugin before 1.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- softaculous Page Builder: Pagelayer – Drag and Drop website builder: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: softaculous Page Builder: Pagelayer – Drag and Drop website builder 1.8.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6ddd1a9e-3f96-4020-9b2b-f818a4d5ba58/
- https://wpscan.com/vulnerability/6ddd1a9e-3f96-4020-9b2b-f818a4d5ba58/
Get alerted when CVE-2023-7115 or the next vulnerability affects your stack