What’s Vulnerable › Vulnerabilities
CVE-2023-7151: Product Enquiry for WooCommerce < 3.2 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Product Enquiry for WooCommerce WordPress plugin before 3.2 does not sanitise and escape the page parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- Product Enquiry for WooCommerce: before 3.2 — fixed in 3.2
How to fix
Upgrade to a fixed version: Product Enquiry for WooCommerce 3.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4992a4a9-f21a-46e2-babf-954acfc7c5b4/
- https://wpscan.com/vulnerability/4992a4a9-f21a-46e2-babf-954acfc7c5b4/
Get alerted when CVE-2023-7151 or the next vulnerability affects your stack