What’s Vulnerable › Vulnerabilities
CVE-2023-7170: EventON-RSVP < 2.9.5 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The EventON-RSVP WordPress plugin before 2.9.5 does not sanitise and escape some parameters before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- EventON-RSVP: before 2.9.5 — fixed in 2.9.5
How to fix
Upgrade to a fixed version: EventON-RSVP 2.9.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/218fb3af-3a40-486f-8ea9-80211a986fb3/
- https://wpscan.com/vulnerability/218fb3af-3a40-486f-8ea9-80211a986fb3/
Get alerted when CVE-2023-7170 or the next vulnerability affects your stack