What’s Vulnerable › Vulnerabilities
CVE-2023-7203: Smart Forms < 2.6.87 - Subscriber+ Arbitrary Entry Deletion
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-27 · updated 2026-06-17
- Weakness: CWE-352
Description
The Smart Forms WordPress plugin before 2.6.87 does not have authorisation in various AJAX actions, which could allow users with a role as low as subscriber to call them and perform unauthorised actions such as deleting entries. The plugin also lacks CSRF checks in some places which could allow attackers to make logged in users perform unwanted actions via CSRF attacks such as deleting entries.
Affected products
- Smart Forms: before 2.6.87 — fixed in 2.6.87
How to fix
Upgrade to a fixed version: Smart Forms 2.6.87. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b514b631-c3e3-4793-ab5d-35ed0c38b011/
- https://wpscan.com/vulnerability/b514b631-c3e3-4793-ab5d-35ed0c38b011/
Get alerted when CVE-2023-7203 or the next vulnerability affects your stack