What’s Vulnerable › Vulnerabilities
CVE-2023-7206: Horner Automation Cscape Stack-Based Buffer Overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-15 · updated 2026-06-17
- Weakness: CWE-121
Description
In Horner Automation Cscape versions 9.90 SP10 and prior, local attackers are able to exploit this vulnerability if a user opens a malicious CSP file, which would result in execution of arbitrary code on affected installations of Cscape.
Affected products
- Horner Automation Cscape: before 9.90; 9.90, 9.90-sp1, 9.90-sp10, 9.90-sp2, 9.90-sp3, 9.90-sp4 (+6) — fixed in 9.90
How to fix
Upgrade to a fixed version: Horner Automation Cscape 9.90. Check the vendor advisory for mitigations.
References
- https://hornerautomation.com/cscape-software/
- https://www.cisa.gov/news-events/ics-advisories/icsa-24-011-04
- https://hornerautomation.com/cscape-software/
- https://www.cisa.gov/news-events/ics-advisories/icsa-24-011-04
Get alerted when CVE-2023-7206 or the next vulnerability affects your stack