What’s Vulnerable › Vulnerabilities
CVE-2023-7235
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-21 · updated 2026-06-17
- Weakness: CWE-276
Description
The OpenVPN GUI installer before version 2.6.9 did not set the proper access control restrictions to the installation directory of OpenVPN binaries when using a non-standard installation path, which allows an attacker to replace binaries to run arbitrary executables.
Affected products
- Openvpn Gui: before 2.6.9 — fixed in 2.6.9
How to fix
Upgrade to a fixed version: Openvpn Gui 2.6.9. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/openvpn/wiki/CVE-2023-7235
- https://community.openvpn.net/openvpn/wiki/CVE-2023-7235
Get alerted when CVE-2023-7235 or the next vulnerability affects your stack