What’s Vulnerable › Vulnerabilities

CVE-2023-7245

Description

The nodejs framework in OpenVPN Connect 3.0 through 3.4.3 (Windows)/3.4.7 (macOS) was not properly configured, which allows a local user to execute arbitrary code within the nodejs process context via the ELECTRON_RUN_AS_NODE environment variable

Affected products

How to fix

Upgrade to a fixed version: OpenVPN Connect 3.4.4, 3.4.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-7245 or the next vulnerability affects your stack