What’s Vulnerable › Vulnerabilities
CVE-2023-7258: Denial-of-Service in Gvisor
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-15 · updated 2026-06-17
- Weakness: CWE-400
Description
A denial of service exists in Gvisor Sandbox where a bug in reference counting code in mount point tracking could lead to a panic, making it possible for an attacker running as root and with permission to mount volumes to kill the sandbox. We recommend upgrading past commit 6a112c60a257dadac59962e0bc9e9b5aee70b5b6
Affected products
- Google gVisor: before 20231204.0 — fixed in 20231204.0
How to fix
Upgrade to a fixed version: Google gVisor 20231204.0. Check the vendor advisory for mitigations.
References
- https://github.com/google/gvisor/commit/6a112c60a257dadac59962e0bc9e9b5aee70b5b6
- https://github.com/google/gvisor/commit/6a112c60a257dadac59962e0bc9e9b5aee70b5b6
Get alerted when CVE-2023-7258 or the next vulnerability affects your stack