What’s Vulnerable › Vulnerabilities
CVE-2023-7299: DataGear resolveSql sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-23 · updated 2026-09-03
- Weakness: CWE-74
Description
A vulnerability was found in DataGear up to 4.60. It has been declared as critical. This vulnerability affects unknown code of the file /dataSet/resolveSql. The manipulation of the argument sql leads to sql injection. The attack can be initiated remotely. Upgrading to version 4.7.0 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- DataGear: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: DataGear 4.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/datageartech/datagear/issues/29
- https://vuldb.com/?ctiid.285658
- https://vuldb.com/?id.285658
- https://vuldb.com/?submit.442943
Get alerted when CVE-2023-7299 or the next vulnerability affects your stack